On 2010-07-13, at 3:33 PM, Erick Lavoie wrote:
execMachineCodeBlock(block) ==> block.exec() freeMachineCodeBlock(block) ==> block.free()
Totally agree to more meaningful, shorter and OOP names. Those are preliminary "hacks" made by Marc to test the system. The final system and exact syntax are completely open for discussion.
OOP names... what's that?
Those names were chosen because they are foreign functions (written in C) and it is in this style that D8 exports foreign functions to JavaScript. Here "block" is an internal array of bytes (I'm not sure it can have properties).
Of course these foreign functions could be wrapped in objects. But given that these are temporary, I don't think we should spend too many brain cycles on it.
- In the spirit of keeping names short and simple, perhaps
a.immediateValue could become a.imm, and a.label(a.codeBlock.label('string')) could simply be a.label('string').
Agreed. I am waiting to get a little more experience with the system before committing to a syntax.
Sounds good. Except it should be a.label("string"). ;-)
Marc