[gambit-list] Compiling Gambit under Termux/Android

Phil Bewig pbewig at gmail.com
Thu May 11 13:02:46 EDT 2017


I did the following experiment with GnuRoot. I wrote the standard hello.c
program, then compiled it with gcc. An ls -l shows a.out with permissions
660. Then I did chmod +x a.out, and the permissions were unchanged. When I
tried to run ./a.out, I got a permission denied error.

Ouch!

Then I did the same experiment with Termux. Gcc was smart enough to set the
execute bit itself, with permissions 700. No need for chmod. Running the
program produced the proper output.

Hello, world!

I'll try again later to compile Gambit on Termux, and let you know how I
get along.

Phil

On Thu, May 11, 2017 at 9:56 AM, Hendrik Boom <hendrik at topoi.pooq.com>
wrote:

> On Thu, May 11, 2017 at 08:29:14AM -0500, Phil Bewig wrote:
> > I had never heard of GnuRoot before this thread, and I was already
> annoyed
> > at the non-standard paths in Termux, so I decided to look at GnuRoot.
> >
> > I downloaded GnuRoot at lunch yesterday, then discovered I needed GnuRoot
> > Wheezy as well, then when I ran that it told me those two options were
> > obsolete and I needed GnuRoot Debian, so I uninstalled the other two and
> > downloaded that. Looked fine. I then did 'apt-get update' and got an
> error
> > message. It turns out that my employer blocks the Debian sites, for some
> > reason.
> >
> > So yesterday evening I did 'apt-get update' and 'apt-get upgrade'; that
> > took a while. Then I tried to wget the Gambit tgz file, but discovered
> > neither wget nor curl is automatic with GnuRoot Debian, so I fetched
> both.
> >
> > Then I downloaded Gambit, untarred, and did './configure'. But configure
> > wasn't executable, so it didn't work. I said 'chmod 777 configure' but
> the
> > execute bit still wasn't set. Searching Google I discovered that error
> > occurs because the sd card is mounted noexec, but I don't have an sdcard,
> > so I'm baffled.
>
> sdcard is part of android.  In the past it was an actual sd card, but
> now it is an area of the disk where the user can put files.  Refussal to
> execute anything there is in order to keep the user from mssing with
> anything that's really android.
>
> You are likely hitting a deliberate android limitation that
> gnuroot is unable to get around.
>
> -- hendrik
> _______________________________________________
> Gambit-list mailing list
> Gambit-list at iro.umontreal.ca
> https://webmail.iro.umontreal.ca/mailman/listinfo/gambit-list
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: http://webmail.iro.umontreal.ca/pipermail/gambit-list/attachments/20170511/3fe7939e/attachment.html 


More information about the Gambit-list mailing list