[gambit-list] Difficulty with Gambit

Herr misterherr at freenet.de
Thu Feb 14 04:35:26 EST 2013

Am 13.02.2013 15:24, schrieb Eduardo Costa:
> I don't think that the problem is not finding gsi. After all, the server finds any
other Scheme, Common Lisp, Forth, etc. but fails to work with gsi. Do you think it
could be a name crash? However, I tried to compile gambit as a standalone, with
another name, and it did not work. By the way, I tried the complete path, as you
suggested, and it didn't work either.
> From: Herr <misterherr at freenet.de>
> To: gambit-list at iro.umontreal.ca
> Sent: Wednesday, February 13, 2013 7:08 AM
> Subject: Re: [gambit-list] Difficulty with Gambit
> Am 08.02.2013 04:47, schrieb Eduardo Costa:
> > One year or so ago, I contacted this list about running Gambit on Linux (I compiled
> > the programs on Zorin/Ubuntu, and tried to run them on a choice of Linux hosting
> > services). My programs work perfectly well in about every Scheme compiler, except
> > Gambit. For instance, they run on Bigloo, Racket, Larceny, Ikarus, Vicare, Chez, to
> > name a few. The programs also run on  Dorai's Scheme to Common Lisp compiler. I tried
> > the Scheme to Common Lisp compiler with SBCL, CMUCL, CLISP, ECL, etc. However, they
> > don't run on Gambit. Although the production code is quite complex (for instance, it
> > includes Serrano's sqlite clone), I wrote a very simple example in order to show what
> > the problem is:
> >
> > #! ./gsi -:d-
> > (display "Content-type: text/html")
> > (newline)
> > (newline)
> >
> > The error is:
> >
> > Internal Server Error
> >
> > The server encountered an internal error or misconfiguration and was unable to
> > complete your request.
> >
> I think the server does not find gsi. Do it like this, works fine here:
> #!/usr/bin/env gsi
> (display "Content-Type: text/html")

My first reaction: Please reply to the list, or the gmane newsgroup.

Then I think, this is clearly an installation problem, but from here I can not tell

The web server executes CGI programs in a separate process, so there is little
linkage to web server internals. If you can execute shell scripts in the same cgi-bin
directory then apache config is okay.

I get an Internal Server Error with apache when a cgi script is not executable. This
can be missing x mode bits, interpreter from #!/-line not found, or even architecture
mismatch 32/64 bit (here the error on the command line is file not found). Turn off
apparmor and selinux.


More information about the Gambit-list mailing list