[gambit-list] Trouble building gambit

Marc Feeley feeley at iro.umontreal.ca
Thu May 11 15:44:02 EDT 2017


That is not the correct way to build Gambit.  The README.md file says:

    git clone https://github.com/gambit/gambit.git
    cd gambit
    ./configure
    make -j4 current-gsc-boot
    ./configure --enable-single-host
    make -j4 from-scratch
    make check
    make -j4 doc
    sudo make install

You are using “make latest-release” which is no longer correct.

Marc



> On May 11, 2017, at 3:31 PM, Faré <fahree at gmail.com> wrote:
> 
> The shared library thing might have been ./configure "remembering" a
> previous configuration attempt. I did a git clean -xfd to remove any
> such thing and indeed I didn't have to export LD_LIBRARY_PATH after I
> did. But I still fail at: make -l4 from-scratch (sorry I used -j4,
> it's about the same as -l4), in the same way:
> 
> $ (set -x ; git clean -xfd ; git reset --hard ; ./configure ; make -l4
> latest-release ; ./configure --enable-single-host && make -l4
> from-scratch ) |& ~/tmp/gambit.fail.1
> ...
> make[2]: Entering directory '/home/fare/src/scheme/gambit/lib'
> ../gsc-boot -:~~bin=../bin,~~lib=../lib,~~include=../include -f -c
> -check -prelude "(##include\"header.scm\")" _io.scm
> gcc -Wno-unused -Wno-write-strings -Wdisabled-optimization -O1 -fwrapv
> -fno-strict-aliasing -fno-trapping-math -fno-math-errno
> -fschedule-insns2 -fomit-frame-pointer -fPIC -fno-common -mieee-fp
> -mpc64   -I"../include" -c -o "_io.o" -I. -DHAVE_CONFIG_H
> -D___GAMBITDIR="\"/usr/local/Gambit\"" -D___SYS_TYPE_CPU="\"x86_64\""
> -D___SYS_TYPE_VENDOR="\"unknown\"" -D___SYS_TYPE_OS="\"linux-gnu\""
> -D___CONFIGURE_COMMAND="\"./configure '--enable-single-host'"\"
> -D___OBJ_EXTENSION="\".o\"" -D___EXE_EXTENSION="\"\""
> -D___BAT_EXTENSION="\"\"" -D___PRIMAL _io.c -D___LIBRARY
> gcc: error: _io.c: No such file or directory
> gcc: fatal error: no input files
> compilation terminated.
> makefile:164: recipe for target '_io.o' failed
> 
> I tried with NixOS and had similar failures. I'll try again and send
> an error log, if that helps.
> 
> —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
> If once you have paid him the Dane-geld / You never get rid of the Dane.
>        — Rudyard Kipling
> 
> 
> On Thu, May 11, 2017 at 1:20 PM, Marc Feeley <feeley at iro.umontreal.ca> wrote:
>> For some strange reason Gambit is being linked to a shared library.  With the configure options you used you should get a static linked executable (the generated library is libgambit.a).
>> 
>> In your “steps” you say “make -l4 from-scratch”… I assume the -l4 is a typo when you wrote the message (it should be -j4).
>> 
>> Can you try again fresh with the steps in the README.md .
>> 
>> Marc
>> 
>> 
>> 
>>> On May 11, 2017, at 12:51 PM, Faré <fahree at gmail.com> wrote:
>>> 
>>> Dear Marc & gambiteers,
>>> 
>>> I am having trouble trying to build gambit from HEAD (commit 75ce77b)
>>> on Linux x64 (Ubuntu 17.04).
>>> 
>>> These steps work well:
>>> ./configure ; make -j4 latest-release ; ./configure --enable-single-host
>>> 
>>> This step fails:
>>> make -l4 from-scratch
>>> 
>>> First, I get:
>>> make[2]: Entering directory '/home/fare/src/scheme/gambit/lib'
>>> ../gsc-boot -:~~bin=../bin,~~lib=../lib,~~include=../include -f -c
>>> -check -prelude "(##include\"header.scm\")" _io.scm
>>> ../gsc-boot: error while loading shared libraries: libgambit.so:
>>> cannot open shared object file: No such file or directory
>>> makefile:167: recipe for target '_io.c' failed
>>> 
>>> If I instead use:
>>> LD_LIBRARY_PATH=$PWD make -l4 from-scratch
>>> 
>>> then gsc-boot can see libgambit.so in the current directory and
>>> compile _io.c, but I get this failure in _num.c:
>>> make[2]: Entering directory '/home/fare/src/scheme/gambit/lib'
>>> ../gsc-boot -:~~bin=../bin,~~lib=../lib,~~include=../include -f -c
>>> -check -prelude "(##include\"header.scm\")" _io.scm
>>> gcc -Wno-unused -Wno-write-strings -Wdisabled-optimization -O1 -fwrapv
>>> -fno-strict-aliasing -fno-trapping-math -fno-math-errno
>>> -fschedule-insns2 -fomit-frame-pointer -fPIC -fno-common -mieee-fp
>>> -mpc64   -I"../include" -c -o "_io.o" -I. -DHAVE_CONFIG_H
>>> -D___GAMBITDIR="\"/usr/local/Gambit\"" -D___SYS_TYPE_CPU="\"x86_64\""
>>> -D___SYS_TYPE_VENDOR="\"unknown\"" -D___SYS_TYPE_OS="\"linux-gnu\""
>>> -D___CONFIGURE_COMMAND="\"./configure '--enable-single-host'"\"
>>> -D___OBJ_EXTENSION="\".o\"" -D___EXE_EXTENSION="\"\""
>>> -D___BAT_EXTENSION="\"\"" -D___PRIMAL _io.c -D___LIBRARY
>>> ../gsc-boot -:~~bin=../bin,~~lib=../lib,~~include=../include -f -c
>>> -check -prelude "(##include\"header.scm\")" _num.scm
>>> *** ERROR IN c#macro-expand -- define-prim can't inline
>>> ##fxwraparithmetic-shift?
>>> makefile:167: recipe for target '_num.c' failed
>>> make[2]: *** [_num.c] Error 70
>>> 
>>> Am I doing something wrong? Is some inline definition for << or >> missing?
>>> 
>>> Also, is there a guide to interactive development with Gambit? I admit
>>> that coming from the Common Lisp world, I'm a bit spoiled by SLIME.
>>> 
>>> —♯ƒ • François-René ÐVB Rideau •Reflection&Cybernethics• http://fare.tunes.org
>>> It's not ignorance that does so much damage;
>>> it's knowing so darned much that ain't so. — Josh Billings
>>> _______________________________________________
>>> Gambit-list mailing list
>>> Gambit-list at iro.umontreal.ca
>>> https://webmail.iro.umontreal.ca/mailman/listinfo/gambit-list
>> 



More information about the Gambit-list mailing list