[gambit-list] Anything particular needed to compile on FreeBSD? 'make' on the compilation of the ~fourth file gives: error: 'openpty' was not declared in this scope

Mikael mikael.rcv at gmail.com
Thu Feb 21 23:26:52 EST 2013

The compilation error is:

error: 'openpty' was not declared in this scope

This was tried on latest FreeBSD 9.0 AMD64 with the gcc46 package
installed, i.e., pkg_add -r gcc46; CXX=/usr/local/bin/g++46 ./configure
--enable-cplusplus --enable-single-host; make .

I tried with both the source for 4.6.6 and 4.6.7 as found on the repo today.

This entire prob made me think maybe there's some operating system headers
file package or alike that I missed, though I would guess not as Gambit not
has any dependencies apart from what's really core to a C compiler and
standard OS and the configure step should have failed if there's any issues
with those.

Also, googling for it does not make me anywiser - apparently lots of people
speak about crosscompat issues, which is unrelated to the question of it
being defined at all, which this error seems to regard.

Can anyone else reproduce this problem?

Any clue what it might be / how to resolve it?

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.iro.umontreal.ca/pipermail/gambit-list/attachments/20130222/2d44570b/attachment.htm>

More information about the Gambit-list mailing list