[gambit-list] Error with iOS 5.0

Adam King akingcoder at gmail.com
Tue Jun 14 22:15:12 EDT 2011

  I've been trying to figure out why some gambit scheme code has stopped
working under iOS 5.0 beta1.  It works fine under 4.3 and the 5.0 simulator,
but errors out on the actual iPad running 5.0.  Here's the code:

     (list path: (##scm-resource "test.scm"))
     (lambda () (println "HI"))

Prints "HI" under 4.3 (sim and device) and 5.0 sim - but throws: "Operation
not permitted" on a 5.0 device.  Any ideas?  Also (load) has stopped
working, throwing the same error.  Yes, 5.0 is under NDA - but I'm not
talking about any new api or features.  Could it be due to more strict file
perms?  I tried accessing the file from both the app bundle and under
'Documents' - no difference.  Thanks
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://mailman.iro.umontreal.ca/pipermail/gambit-list/attachments/20110614/addd0470/attachment.htm>

More information about the Gambit-list mailing list