[gambit-list] A couple of random questions

mikel evins mevins at me.com
Sun Jul 31 16:48:27 EDT 2011

On Jul 31, 2011, at 6:50 AM, Marc Feeley wrote:

> I have encountered this problem also (with Lion and the new Xcode).  The problem is due to LLVM gcc which is the default C compiler now and which does not compile the Gambit sources properly when the --enable-single-host configure option is given.  I've tried using gdb to find where the error is, but it is giving me an execution trace which doesn't correlate with the sources so I am confused in regards to the location of the error.
> So to fix the problem temporarily I did
>   CC="i686-apple-darwin11-gcc-4.2.1" ./configure --enable-single-host
>   make
>   make check
> I also committed a patch to look for "i686-apple-darwin11-gcc-4.2.1" before "gcc", but that is not a long term solution.
> My guess is that LLVM gcc is buggy, but I have not yet found a proof.

Using the above workaround, I certainly get farther than before. I can make it through the make check without crashes or errors.

After that, I tried this:

1. rm examples/iOS/Prefix.pch (needed because otherwise make update fails when git is unable to update that file)

2. make update

3. cd examples/iOS

4. make examples

5. ./build-gambit-iOS

A cursory examination seems to show that these steps all succeeded, but I'm unable to run Gambit-REPL in the iPad or iPhone simulator. It launches and immediately crashes, complaining that it can't access memory address 1.

Perhaps I need to alter the Makefiles used in the iOS build to ensure that LLVM is not used? Or perhaps I overlooked some other step?


More information about the Gambit-list mailing list