[gambit-list] No echo of input to gsi

Marc Feeley feeley at iro.umontreal.ca
Sat Aug 19 12:15:52 EDT 2006

On 2-Aug-06, at 2:21 PM, bn wrote:

>  Dear list readers,
> I have a problem with gambit 40b17 on cygwin/WinXP. I compiled  
> gambit with gcc3.4.4 and it seemed to work.
> But gsi.exe does not echo the characters I type into the terminal  
> (bash or DOS cmd). I tried various -:- and -:t options but with
> no success. However, the result of the evaluation of what I typed  
> gets printed.
> Any help would be appreciated

I could not reproduce your problem.  I compiled 4.0 beta 17 with the  
latest cygwin with gcc 3.4.4 and the console I/O worked fine.  Are  
you using special tty settings in your shell?  What does the shell  
command "stty" report?

If you can't solve the problem with cygwin, you might try compiling  
Gambit with MinGW.  There is a different I/O problem with MinGW  
(which has been fixed in my working version).  You will have to start  
gsi with the option -:tl (the console end-of-line processing for CR- 
LF in beta 17 has a bug).


More information about the Gambit-list mailing list